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Introduction

Microsoft has included in the Office 97 Professional release the ability of a user to “share” an Excel workbook in a collaborative development environment.  This document has been developed to provide a synopsis of information and instructions that will assist all users in getting the most out of this collaborative tool.

Quick Reference

The following set of instructions provides a quick reference to the procedures for sharing a Microsoft Excel Workbook.  For a more detailed set of instructions, please refer to Section 3 of this document - Detailed Information.  Also

1. Open the Microsoft Excel Workbook that will be “shared” in a collaborative environment.  (NOTE: If this workbook is a template for future tasking, then ensure the “shared workbook” is a copy of the template.)

2. From the tool bar, select: Tools, Share Workbook, Editing, Allow changes by more than one user at the same time, and then click OK.

3. Also the tool bar, select the appropriate AutoSave, Track Changes, and Protection options.

4. Ensure all other collaborative users have network access to the “shared” workbook.

5. Have the collaborative users open the “shared” workbook.

6. All collaborative users should:

a. Ensure the computers date and time are synchronized.

b. AutoSave options are set to the appropriate settings for the collaborative environment requirements.

7. To ensure important data is immediately available to all collaborative users, the user must “Save” the Excel workbook.

8. To ensure your screen is displaying the latest information, “Save” the Excel workbook. 

Frequently Asked Questions
Worksheet Protection of Columns, Rows, or Cells.

Question: Can a number of column, rows, or cells be protected against changing the information, specifically contents relating to titles and/or headings?

Answer:  One method to accomplish this is to accomplish the following procedures:

1) Click on the worksheet “select all” command button – the little unlabeled command button at the upper left corner of the rows and columns.

2) On the Excel toolbar, select: Format, Cells…, Protection Tab, ensure the “Locked” checkbox is clear, and select OK.

3) Click on any cell to have Excel focus on one cell instead of all rows and columns.

4) Select the rows, columns, and/or cells to be protected.

5) On the Excel toolbar, select: Format, Cells…, Protection Tab, click on the “Locked” checkbox (a check mark should appear), and select OK.

6) Click on any cell to have Excel focus on one cell instead of the highlighted rows, columns, and/or cells.

7) On the Excel toolbar, select: Tools; Protection; Protect Worksheet; and then select “Contents” (a checkmark should be in the checkbox) – objects and scenarios can also be protect.

8) A password can be assigned to the protection of the worksheet.  If a password is entered, Excel will ask for the user to confirm the password after selecting OK.

The desired rows, columns, and/or cells are now safeguarded against any content changes while the worksheet is protected.

Cell Formatting When a Worksheet is Protected.

Question:  If the worksheet is protected, can cells formatting be changed.

Answer:  No.  The worksheet protection must be removed, the appropriate reformatting accomplished, and then worksheet protection must be reapplied.

Inserting or Deleting When a Worksheet is Protected.

Question:  When a worksheet is protected, can the user insert or delete a row, column or cell.

Answer:  No.  The worksheet protection must be removed, the appropriate inserting or deleting actions accomplished, and then worksheet protection must be reapplied.

Removing protection.

Question:  How is worksheet protection removed?

Answer:  To remove these restrictions, users must remove protection from the worksheet with the Unprotect Worksheet command (Tools menu, Protection submenu) and can do so only if they know the password. 
Computer Date and Time Synchronization

Question:  Is it recommended to date/time synchronize the computers that are working in an collaborative environment?

Answer:  During the use of “shared workbooks” in a collaborative environment, all computers should have synchronized dates and times.  If not, then the changes will contain the incorrect date and time stamps, which could cause change tracking inconsistencies, plus the possibility of an outdated change from being accepted. 

Detailed Instructions and Information

Share a workbook with other users.

With Microsoft Excel and other Microsoft Office programs, you can share files with other people and work on the data collaboratively.  If you want several users to work on the data in the same workbook simultaneously, you can save the workbook as a shared workbook, and then make it available on your network. You can place the shared workbook on a shared network directory or in a shared folder on your computer.

About shared workbooks.  

Viewing and changing a shared workbook differs from working in a workbook that is not shared in the following ways:

a. To make changes to a shared workbook created in Microsoft Excel 97, you must use Microsoft Excel 97. You cannot use earlier versions of Microsoft Excel. You can work on the same shared workbook from both Windows and Macintosh computers if both computers are running Microsoft Excel 97.

b. When you make changes to a shared workbook, Microsoft Excel uses your user name to identify your work. To set your user name, click Options on the Tools menu, and then click General. Type your user name in the User name box.

c. Some Microsoft Excel commands and operations are not available in a shared workbook.  See paragraph 10 of this document for some of the most common restrictions and limitations.

d. If more than one user adds a comment to the same cell in a shared workbook, the text of all saved comments for the cell appears when each user saves the shared workbook. 

e. By default, you see changes made by other users whenever you save the shared workbook. If you prefer, you can get these updates automatically at specified intervals. Each user can specify a different update interval. 

Tip:  The basic Microsoft Excel “autosave” smallest time interval is five (5) minutes.  By following these procedures, the autosave process can be lowered to one (1) minute – on the main tool bar:

· Select Tools, Add-Ins…

· Take the mouse and left click a “check-mark” in the “AutoSave” selection.  Then select OK.

· Select Tools and click on AutoSave… This selection will have a grayed out “check-mark” but ignore this and click on AutoSave…

· Review the settings on the “AutoSave” window and make the appropriate selections for your environment.

f. By default, if changes you are saving conflict with changes saved by another user, Microsoft Excel displays the Resolve Conflicts dialog box so that you can decide whether to save your changes or keep the changes made by others. You can also choose to save your changes automatically instead of conflicting changes, so that you never see the dialog box.

g. By default, each user can save personal filter and print settings for a shared workbook.

h. You can view a complete list of changes to the workbook, including the names of the users who made the changes, data that was deleted or replaced, and information about conflicting changes.

Set up a shared workbook.

a. On the Tools menu, click Share Workbook, and then click the Editing tab.

1) Select the Allow changes by more than one user at the same time check box.

2) Then click OK.

b. When prompted, save the workbook.

c. On the File menu, click Save As, and then save the shared workbook on a network location where other users can gain access to it.

d. Additional Information:

1) If you copy the shared workbook to a network location, make sure any links to other workbooks or documents are intact. Use the Links command on the Edit menu to make corrections to the link definitions.

2) This procedure also turns on the change history, which allows you to view information about changes to the shared workbook and about conflicting changes that are kept or discarded. When you maintain the change history, you can also make copies of the shared workbook that you can merge together after they have been changed.

3) All users who have access to the network location where a shared workbook is stored have the same access to the shared workbook. If you want to prevent certain types of access to a shared workbook, you can protect the shared workbook and the change history.

Prepare copies of a workbook to be reviewed and merged.  

When you merge several copies of a shared workbook in which users have entered changes, Microsoft Excel requires that each copy of the shared workbook maintain the change history from the day when you create the copies through the day when you merge them. If the number of days you specified has been exceeded, you can no longer merge the copies. If you aren't sure how long the review process will take, make sure you maintain the change history for a sufficient number of days, or enter a large number of days, such as 1,000.

a. On the Tools menu, click Share Workbook.

b. Click the Editing tab.  Select the Allow changes by more than one user at the same time check box.

c. Click the Advanced tab.

1) Under Track changes, click Keep change history for.

2) In the Days box, type a number at least as long as the number of days you expect reviewers to spend making changes and comments in the shared workbook.

d. Click OK, and save the file.

e. To make copies of the workbook that you can distribute to reviewers, click Save As on the File menu. Give each copy a different name.

Note:  To make sure reviewers don't turn off the change history, you can require that the change history be maintained before you make the copies and distribute them.

Review and incorporate changes.

a. On the Tools menu, point to Track Changes, and then click Accept or Reject Changes.

b. If prompted to save the workbook, click OK.

c. Select the changes to review.

1) To review changes made by another user, select the Who check box, and then click the user in the Who box.

2) To review changes by all users, clear the Who check box.

d. To review changes to a specific area on a worksheet, select the Where check box, and then enter a reference to the area.

e. To review changes to the entire workbook, clear the Where check box.

f. Click OK, and then read the information about the first change in the Accept or Reject Changes dialog box. The information also describes any dependent changes that are affected by the action you take for this change. You may need to use the scroll arrows to see additional information.

g. To accept the change and clear its change highlighting, click Accept.

h. To undo the change on the worksheet, click Reject.

i. If prompted to select a value for a cell, click the value you want, and then click Accept.

j. Repeat the above steps for each change, or click Accept All or Reject All to accept or reject all remaining changes. You must accept or reject a change before you can advance to the next change.

Note:  You can view information about rejected changes, including any data that was deleted. On the History worksheet, rejected changes display "Undo" or "Result of rejected action" in the Action Type column. For information about displaying the History worksheet, click  .

Merge changes from multiple copies of the same workbook.  

If you plan to merge copies of a shared workbook, you must turn on the change history for the shared workbook before you make the copies for distribution to reviewers and before anyone makes any changes to the copies. You also must complete the merge within the time period you specified to maintain the change history. For information about preparing copies of a shared workbook for review and merging, including setting the time period for the change history,

a. Open the copy of the shared workbook into which you want to merge changes from another workbook file on disk.

b. On the Tools menu, click Merge Workbooks.

c. If prompted, save the shared workbook.

d. In the Select Files to Merge Into Current Document dialog box, click a copy of the shared workbook that has changes to be merged, and then click OK.

e. Repeat the above steps until all copies of the shared workbook are merged.

Note:  If a cell contains a comment, the comment includes the name of the person who inserted the comment. When you merge shared workbooks and a cell has comments from more than one person, the comments appear one after another in the comment box for the cell.

Tip:  If you want to merge several copies of a workbook in one step, you can select more than one workbook in the Select Files to Merge Into Current Document dialog box by holding down CTRL or SHIFT and then clicking the file names.

Remove a user from a shared workbook.  

When a user closes a shared workbook, Microsoft Excel disconnects the user from the shared workbook. Use this procedure to remove a user who appears to be connected to a shared workbook but is no longer working in the workbook or whose network connection is broken.  (Caution: When you remove a user who is currently working in a shared workbook, the user's unsaved work will be lost.)
a. On the Tools menu, click Share Workbook, and then click the Editing tab.

b. In the Who has this workbook open now box, click the name of the user you want to disconnect, and then click Remove User.

Tip:  If a user no longer needs to work with a shared workbook, you can reduce the size of the workbook file by deleting the user's personal view settings. On the View menu, click Custom Views. In the Views box, click the user's view, and then click Delete.

Limit what others can see and change in a shared workbook.  

If the workbook you want to protect is already shared, and you want to assign a password to protect the sharing or you want to protect other worksheet or workbook features, remove the workbook from shared use.

a. If you want to require that users supply a password to open the shared workbook, set this password.

b. If you want to require that users supply a password when they make changes and save the shared workbook, set this password.

c. If you don't want other users to see certain rows or columns on a worksheet, select the rows or columns. On the Format menu, point to Row or Column, and then click Hide.

d. If you want to allow others to change only specific areas of the shared workbook, unlock the areas, and then protect the worksheets. (This action also prevents others from seeing hidden rows or columns.)

e. If you don't want others to see specific worksheets in the shared workbook, click a worksheet, point to Sheet on the Format menu, and then click Hide. Repeat for each worksheet that you want to hide.

f. After you hide the worksheets, you must protect the workbook to keep other users from redisplaying the hidden worksheets. On the Tools menu, point to Protection, and then click Protect Workbook. Select the Structure check box, and then click OK.

g. If you want to change the number of days that Microsoft Excel will maintain the change history for the shared workbook (the default is 30 days), click Share Workbook on the Tools menu, and then click the Editing tab. Select the Allow changes by more than one user at the same time check box, and then click the Advanced tab. Under Track changes, make sure Keep change history for is selected, and then type the number of days you want to maintain the change history in the Days box. Click the Editing tab, clear the Allow changes by more than one user at the same time check box, and then click OK.

h. On the Tools menu, point to Protection, and then click Protect Shared Workbook or Protect and Share Workbook.

1) Select the Sharing with track changes check box.

2) If you want to require other users to supply a password to turn off the change history or remove the workbook from shared use, type the password in the Password box, and then reenter the password when prompted.

3) When prompted, save the workbook. This shares the workbook and turns on the change history.

i. Additional Information: 

1) When you protect sharing for a workbook, users cannot remove the workbook from shared use or turn off the change history.

2) In a workbook that is already shared, you can turn on protection for sharing and the change history, but you cannot assign a password for this protection. To assign a password, you must first remove the workbook from shared use.

Keep or discard conflicting changes when you save a shared workbook.  

Use this procedure when you save a shared workbook and see the Resolve Conflicts dialog box.

a. Read the information about your change and any conflicting changes.

b. To keep your change, click Accept Mine.

c. To keep the other person's change, click Accept Other.

1) Repeat the above steps for each change.

2) To keep all of your remaining changes, click Accept All Mine.

3) To keep all of the other users' remaining changes, click Accept All Others.

Tip:  You can save a copy of the workbook with all your changes by clicking Cancel, clicking Save As on the File menu, and then typing a new name for the file.

Note:  If you don't want Microsoft Excel to display the Resolve Conflicts dialog box when you save a shared workbook, you can set an option to save your changes automatically instead of reviewing conflicting changes. 

Limitations of shared workbooks.  

Some features of Microsoft Excel are not available when you use a shared workbook. If you need to use these features, do so before you share the workbook, or remove the workbook from shared use.  In a shared workbook, you cannot do the following:

a. Delete worksheets.

b. Merge cells.

c. Define or apply conditional formats. However, you can see the effects of conditional formats applied before you shared the workbook.

d. Set up or change data validation restrictions and messages. However, you can see the effects of restrictions and messages that were set up before you shared the workbook.

e. Insert or delete blocks of cells. You can insert or delete entire rows and columns.

f. Insert or change charts, pictures, objects, or hyperlinks.

g. Use the drawing tools.

h. Assign a password to protect individual worksheets or the entire workbook. Protection that you applied before sharing the workbook remains in effect after you share the workbook.

i. Change or remove passwords. Passwords that you assigned before sharing the workbook remain in effect after you share the workbook.

j. Save, view, or make changes to scenarios.

k. Group or outline data.

l. Insert automatic subtotals.

m. Create data tables.

n. Create PivotTables or change the layout of existing PivotTables.

o. Make changes to dialog boxes or menus.

p. Write, change, view, record, or assign macros. However, you can record operations in a shared workbook into a macro stored in another workbook that isn't shared. In a shared workbook, you can run macros that were created before you shared the workbook; although if you run a macro that includes an unavailable operation, the macro stops running when it reaches the unavailable operation.

q. You cannot save shared workbooks to Microsoft Exchange public folders.

Closing Comments.  

The Microsoft Excel help menu is an excellent tool in gaining further experience and knowledge on using the “shared” function of Excel workbooks and worksheets.  To illustrate this point, the majority of the information in these document were extracted and compiled using Microsoft Excel Help.

If you have a question (or recommendations) concerning this document, then please address the issue calling, or electronic mail, CECOM/SEC Architecture and Technology Division at Fort Monmouth, New Jersey.  (Currently the appropriate contact information is: Ms. Carol Wortman, 732-532-8135, DSN 88-992-8135, or through electronic mail at Wortman@mail1.monmouth.army.mil.
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